워드프레스에서 발견된 취약점 통해 웹사이트 장악 가능

2019-03-15 15:17
  • 카카오톡
  • url
콘텐츠 관리 시스템의 취약점, 연쇄적으로 공격하는 것 가능해
나중에는 원격에서 PHP 임의 코드를 실행할 수도 있어


[보안뉴스 문가용 기자] 콘텐츠 관리 시스템인 워드프레스(WordPress)가 취약점을 한 개 패치했다. 이 취약점을 익스플로잇 할 경우 인증을 받지 않은 공격자가 원격에서 임의의 코드를 실행하고, 웹사이트를 완전히 장악할 수 있게 된다고 한다.


[이미지 = iclickart]

이 취약점은 워드프레스 5.1.1 이전 버전들 중 댓글 달기를 활성화시킨 경우 발동할 수 있다. 댓글이 필터링 되고 데이터베이스에 저장되는 과정에서 나타나는 것이기 때문이다. 앱 보안 업체인 립스 테크놀로지스(RIPS Technologies)의 시몬 스캐넬(Simon Scannell)은 “사이트 관리자를 특정 도메인으로 접속하도록 꾀어내고, CSRF를 배경에서 익스플로잇 하기 시작하면 공격을 성공시킬 수 있다”고 설명한다. 여러 개의 논리 오류와 필터링 오류를 연쇄적으로 익스플로잇 하는 방식의 공격법이라고 덧붙이기도 했다.

워드프레스 사용자들이 디폴트 설정을 그대로 두었다면 이 공격에 노출될 가능성이 높다. 왜냐하면 디폴트 상 댓글이 허용되어 있기 때문이다. 따라서 립스 테크놀로지스 측은 “수백만 개의 웹사이트가 현재 위험한 상태일 가능성이 높다”는 의견이다.

스캐넬에 의하면 “문제의 핵심은 사용자가 새로운 댓글을 작성했을 때 이에 대한 CSRF 검사를 제대로 진행하지 않는다는 것”이라고 한다. 이 기능이 활성화되어 있다면 트랙백(trackback)이나 핑백(pingback)과 같은 기능이 제대로 작동하지 않는다. “이 부분을 악용하면 공격자가 관리자의 이름으로 댓글을 달 수 있게 됩니다.”

그런데 관리자가 댓글 란에 임의의 HTML 태그를 첨가할 권한이 있다면, 이 문제가 증폭된다. “예를 들어 관리자가 스크립트 태그를 붙일 수 있다면, 해커가 관리자의 이름으로 댓글에 스크립트를 업로드시킬 수 있게 됩니다. 이론상 CSRF 남용을 통해 악성 자바스크립트를 실행시킬 수 있게 되는 겁니다.”

그래서 워드프레스는 관리자들이 댓글 필드에서 사용할 수 있는 넌스를 추가로 생성해 문제를 해결하려 했다. 관리자가 댓글을 남길 때, 이 넌스까지도 함께 제출해야 ‘관리자 댓글’이 성공적으로 입력되도록 말이다.

하지만 스캐넬은 “댓글과 함께 올바른 넌스가 제출됐을 때, 댓글이 생성되긴 하지만 내용에 대한 검사 과정이 생략됐다”고 말한다. “반대로 제출된 넌스가 올바르지 않을 때도 댓글이 생성되긴 하지만, 오히려 내용 검사가 이뤄지더군요.”

이는 논리적 오류다. 스캐넬은 “이 오류 역시 악용할 수 있다”고 설명한다. “일반적으로 댓글 란에 허용되는 것보다 훨씬 많은 HTML 태그나 속성들을 집어넣을 수 있게 됩니다. 이는 워드프레스 환경 내에서 XSS 공격으로 이어질 수 있습니다.”

스캐넬에 의하면 “공격자가 a라는 태그가 포함된 댓글을 만들어 XSS 페이로드를 웹사이트에 주입할 수 있다.” 그 다음으로는 관리자를 속이거나 꾀어 그 자바스크립트를 실행하도록 하면, 공격이 완성된다. “숨겨진 아이프레임 태그(iframe)를 사용하면 관리자가 자바스크립트를 실행하도록 꾀는 게 그리 어렵지 않습니다.”

“원격 코드 실행 취약점은 정말 익스플로잇이 간단합니다. 디폴트 상으로 워드프레스는 관리자가 직접 .php 파일을 편집할 수 있게 해줍니다. 뿐만 아니라 관리자 대시보드로부터 플러그인의 편집도 가능합니다. 공격자가 PHP 백도어를 위의 방법으로 삽입하면 임의의 PHP 코드 실행을 성공시킬 수 있습니다.”

이 취약점은 워드프레스에 보고됐고, 5.1.1 버전을 통해 패치됐다. 워드프레스 사이트를 운영하는 관리자들이라면 시급한 패치가 권고된다. 당장 패치가 어렵다면 댓글 기능이라도 잠그는 것이 필요하다.

3줄 요약
1. 워드프레스에서 치명적인 취약점 발견됨. 이를 통해 연쇄적으로 웹사이트를 장악하는 게 가능함.
2. CSRF 공격과 XSS 공격을 연쇄적으로 실시함으로써 종국엔 임의의 PHP 코드를 실행할 수 있음.
3. 5.1.1 버전으로 업그레이드 하거나 댓글 기능을 잠그는 게 필요함.

[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

이전 스크랩하기

과월호 eBook List 정기구독 신청하기

Copyright Mediadot Corp. All Rights Reserved.

MENU

PC버전

닫기